Delayed password notifications

Incident Report for mxHero, Inc.

Postmortem

Incident duration:
Start: July 10th, 2025, 15:00 UTC
End: July 11th, 2025, 03:00 UTC

Summary:
Between 15:00 UTC on July 10th and 03:00 UTC on July 11th, password notification emails were not always sent when sharing collaborative folders through Box storage. All emails and attachments were processed and delivered successfully; there was no data loss or loss of file access.

Actions taken:

  • The root cause was identified and corrected.
  • The system is now fully operational.
  • All missing password notification emails were identified and successfully resent to affected recipients.
  • Clients seeing storage_rejected errors in their logs during this period, without password notification rules enabled, can safely ignore these events as false positives.

Next steps:
We continue to monitor the system closely. If you have any questions or concerns, please contact our support team.

Posted Jul 11, 2025 - 10:56 UTC

Resolved

We have identified an issue starting at 15:00 UTC on July 10th affecting password notification emails when sharing collaborative folders. All emails and attachments continue to be delivered successfully. We are investigating the issue and will provide updates as soon as possible.
Posted Jul 10, 2025 - 15:00 UTC